Schools Website Service user guide

Minimum computer specifications

To use the School Website Service you will need a PC with the following:

  • A working Internet connection
  • Windows 98, ME, 2000, XP, Vista or 7
  • Internet Explorer 7 or 8, Google Chrome, or Firefox V3
  • Javascript settings enabled
  • Java settings enabled

You can test if your computer meets these specifications - Please note, this checks to see if Java has been enabled but not the version installed on your computer system.

Internet Explorer 9, 10 and 11 are not compatible with the current SWS system that you use to maintain your school websites: the editor function will not work correctly. You may therefore need to downgrade you browser to a compatible version (IE 7 or 8) or use an alternative browser. The advised browser to use is Google Chrome

If you are using the Hosted Schools Service (HSS) you should already have a compatible Internet Explorer browser and Java installed to use SWS:

  • Go to the Start Menu and select School Website Service

  • This will open an internet browser and take you to the Hantsweb homepage where you can browse to your school's website to login

How Java works

  • Java is software installed on your computer that works with the Internet browser to run the Text Wizard.

  • You will be prompted to press Run or Run this time (in Chrome) when you open the Text Wizard and this should load the Java software. If the Java is not run you will need to logout and reload again.

run this time

Errors and bugs with Java

If your Java software is loaded properly or you have an incompatible version installed you may get the following error messages when trying to edit your pages:

"The Content Manager cannot execute the function you selected. Please restart the Content Manager and try again. "Error code - Applet not loaded"

or

"The text could not be loaded. It is possible it was not parsed correctly. Reason iu"

Users may also find that the Spelling checker doesn't work or the 'styles toolbar' disappears within the Text Wizard if an unsupported version of Java is installed.

Incompatible versions of Java can also corrupt the Text Wizard, with only the Editions / Versions panel showing. The main content can still be accessed, although you will have to go to View  and un-tick Editions/ Versions to see this. To resolve this issue your login profile will need to be reset by IT and a compatible version of Java will need to be installed.

Schools using the Hosted School Service may encounter problems with Java due to a conflict between the different versions of Java that these services use. A separate access function has therefore been created for HSS users.

How to check your Java version

At present SWS will work with any version of Java up to Version 6.20 so please do not download (or update plug-in) for the latest version of Java, if prompted. It is fine to use an earlier version than 6.20, but we do recommend that you check first to see what version you have installed. Please follow these instructions:

  • Close all your browser windows;

  • Go to Start, open the Control Panel and double-click on Add or Remove Programs (or Programs and Features in Windows 7 or Vista)

  • You should see one or more versions of Java. If you only have up to version 6.20 - JSE Runtime Environment 1.6.0 Update 20 (where 20 is a number) and no later version installed then that should work fine.

If you do have an incompatible Java version....

  • Select any program related to Java (e.g. Java I SE Runtime Environment 7 Update 1, also known as Java 1.7.0_01) and click on Remove.

  • Make sure you are logged in as an administrator and download and install an earlier version of the software from Java. Scroll down the page until you find the option Java Runtime Environment (JRE) 6.0 Update 20. The J2SE Runtime Environment (JRE) allows end-users to run Java applications. Click the download button.

  • If you do install a 64 bit version of Java please check your system is compatible for this - otherwise please install a 32 bit version.

  • Save the file to a location on your computer that you will be able to find later (eg. Desktop.) When the download has finished find the file that you downloaded and double-click it to install Java version 6.20. Follow the instructions on the screen, accepting any default options.

  • Shut down and re-open your browser and try to open the text wizard.

Java Troubleshooting

  • Java will need to be enabled and the plugin will need to be correctly installed to run.

  • You will also need to allow pop-ups for the website address if pop-up blocker is switched on.

  • If a compatible version of Java is installed but it does not 'Run' correctly please check your Java settings to ensure it is correctly configured.

Further Support

If you have tested your computer and it appears to meet the specifications and you have downloaded the correct version of Java, but you still get an error message when trying to open the text wizard  then please report this via the online form